// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(...)(\/([nsbpif]))+ ([\d])").unwrap();
let string = "Aaa/n 0
Bbb/b/p 0
Ccc/b/n/p 3";
let substitution = "@\"$1\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}