use strict;
my $str = 'Aaa/n 0
Bbb/b/p 0
Ccc/b/n/p 3';
my $regex = qr/(...)(\/([nsbpif]))+ ([\d])/p;
my $subst = '@"$1"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";