using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(...)(\/([nsbpif]))+ ([\d])";
string substitution = @"@""$1""";
string input = @"Aaa/n 0
Bbb/b/p 0
Ccc/b/n/p 3";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}