#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^jdbc:postgresql:(?://[^/]+/)?(\w+)"
Local $sString = "jdbc:postgresql:databasename" & @CRLF & _
"jdbc:postgresql://host/database_a" & @CRLF & _
"jdbc:postgresql://host:5432/database_123" & @CRLF & _
"jdbc:postgresql://localhost/database?user=fred&password=secret&ssl=true"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")