use strict;
my $str = 'jdbc:postgresql:databasename
jdbc:postgresql://host/database_a
jdbc:postgresql://host:5432/database_123
jdbc:postgresql://localhost/database?user=fred&password=secret&ssl=true';
my $regex = qr~^jdbc:postgresql:(?://[^/]+/)?(\w+)~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}