re = /^jdbc:postgresql:(?:\/\/[^\/]+\/)?(\w+)/m
str = 'jdbc:postgresql:databasename
jdbc:postgresql://host/database_a
jdbc:postgresql://host:5432/database_123
jdbc:postgresql://localhost/database?user=fred&password=secret&ssl=true'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end