import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^jdbc:postgresql:(?://[^/]+/)?(\\w+)";
final String string = "jdbc:postgresql:databasename\n"
+ "jdbc:postgresql://host/database_a\n"
+ "jdbc:postgresql://host:5432/database_123\n"
+ "jdbc:postgresql://localhost/database?user=fred&password=secret&ssl=true";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}