// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^jdbc:postgresql:(?://[^/]+/)?(\w+)").unwrap();
let string = "jdbc:postgresql:databasename
jdbc:postgresql://host/database_a
jdbc:postgresql://host:5432/database_123
jdbc:postgresql://localhost/database?user=fred&password=secret&ssl=true";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}