using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^jdbc:postgresql:(?://[^/]+/)?(\w+)";
string input = @"jdbc:postgresql:databasename
jdbc:postgresql://host/database_a
jdbc:postgresql://host:5432/database_123
jdbc:postgresql://localhost/database?user=fred&password=secret&ssl=true";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}