const regex = new RegExp('^jdbc:postgresql:(?://[^/]+/)?(\\w+)', 'gm')
const str = `jdbc:postgresql:databasename
jdbc:postgresql://host/database_a
jdbc:postgresql://host:5432/database_123
jdbc:postgresql://localhost/database?user=fred&password=secret&ssl=true`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}