# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\h*\S.*)\R\s*^(\h*\S.*)\R\s*^(?=\/{24})/$1 $2\n/gm;t' <<< "1.58%
0009
1991
/////////////////////////
Phil
ttr0018
1991
/////////////////////////"