import Foundation
let pattern = #"^(\h*\S.*)\R\s*^(\h*\S.*)\R\s*^(?=/{24})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1.58%
0009
1991
/////////////////////////
Phil
ttr0018
1991
/////////////////////////
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)