re = /^(\h*\S.*)\R\s*^(\h*\S.*)\R\s*^(?=\/{24})/m
str = '1.58%
0009
1991
/////////////////////////
Phil
ttr0018
1991
/////////////////////////'
subst = '$1 $2\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result