using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\h*\S.*)\R\s*^(\h*\S.*)\R\s*^(?=/{24})";
string substitution = @"$1 $2\n";
string input = @"1.58%
0009
1991
/////////////////////////
Phil
ttr0018
1991
/////////////////////////";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}