#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\*([^*]+)\*"
Local $sString = "What kind of *vegetable* is it?" & @CRLF & _
                "I hope I am not late." & @CRLF & _
                "All *the good* shows are *no longer* broadcasting." & @CRLF & _
                "This line contains entries with numbers (*1+2=3*) and punctuation too (*this is a sentence.*)"
Local $sSubst = "<b>$1</b>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)