import re
regex = re.compile(r"\*([^*]+)\*")
test_str = ("What kind of *vegetable* is it?\n"
"I hope I am not late.\n"
"All *the good* shows are *no longer* broadcasting.\n"
"This line contains entries with numbers (*1+2=3*) and punctuation too (*this is a sentence.*)")
subst = "<b>$1</b>"
result = regex.sub(subst, test_str)
if result:
print(result)