// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\*([^*]+)\*").unwrap();
let string = "What kind of *vegetable* is it?
I hope I am not late.
All *the good* shows are *no longer* broadcasting.
This line contains entries with numbers (*1+2=3*) and punctuation too (*this is a sentence.*)";
let substitution = "<b>$1</b>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}