$re = '/\*([^*]+)\*/';
$str = 'What kind of *vegetable* is it?
I hope I am not late.
All *the good* shows are *no longer* broadcasting.
This line contains entries with numbers (*1+2=3*) and punctuation too (*this is a sentence.*)';
$subst = "<b>$1</b>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;