use strict;
my $str = 'What kind of *vegetable* is it?
I hope I am not late.
All *the good* shows are *no longer* broadcasting.
This line contains entries with numbers (*1+2=3*) and punctuation too (*this is a sentence.*)';
my $regex = qr/\*([^*]+)\*/p;
my $subst = '<b>$1</b>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";