package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\*([^*]+)\*`)
var str = `What kind of *vegetable* is it?
I hope I am not late.
All *the good* shows are *no longer* broadcasting.
This line contains entries with numbers (*1+2=3*) and punctuation too (*this is a sentence.*)`
var substitution = "<b>$1</b>"
fmt.Println(re.ReplaceAllString(str, substitution))
}