# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/["'][\s\S]+?["']//gm;t' <<< "1,2,3,\"a,b,c,d,e\",4,\"f,g,h\""