use strict;
my $str = '1,2,3,"a,b,c,d,e",4,"f,g,h"';
my $regex = qr`["'][\s\S]+?["']`mp;
my $subst = '';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";