using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[""'][\s\S]+?[""']";
string substitution = @"";
string input = @"1,2,3,""a,b,c,d,e"",4,""f,g,h""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}