const regex = new RegExp('["\\'][\\s\\S]+?["\\']', 'gm')
const str = `1,2,3,"a,b,c,d,e",4,"f,g,h"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);