$re = '`["\'][\s\S]+?["\']`m';
$str = '1,2,3,"a,b,c,d,e",4,"f,g,h"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;