re = /["'][\s\S]+?["']/m
str = '1,2,3,"a,b,c,d,e",4,"f,g,h"'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result