#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.+D )\d{4}"
Local $sString = "Priority Controller DB8009 120D 4312" & @CRLF & _
"Priority Controller DB8009 120D 4312" & @CRLF & _
"Priority Controller DB8008 130D 4000" & @CRLF & _
"Priority Controller DB8009 110D 4222" & @CRLF & _
"Priority Controller DB8008 120D 3000" & @CRLF & _
"Priority Controller DB8009 120D 2000" & @CRLF & _
"Priority Controller DB8009 110D 6003"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")