$re = '/(.+D )\d{4}/m';
$str = 'Priority Controller DB8009 120D 4312
Priority Controller DB8009 120D 4312
Priority Controller DB8008 130D 4000
Priority Controller DB8009 110D 4222
Priority Controller DB8008 120D 3000
Priority Controller DB8009 120D 2000
Priority Controller DB8009 110D 6003';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);