import re
regex = re.compile(r"(.+D )\d{4}", flags=re.MULTILINE)
test_str = ("Priority Controller DB8009 120D 4312\n"
"Priority Controller DB8009 120D 4312\n"
"Priority Controller DB8008 130D 4000\n"
"Priority Controller DB8009 110D 4222\n"
"Priority Controller DB8008 120D 3000\n"
"Priority Controller DB8009 120D 2000\n"
"Priority Controller DB8009 110D 6003")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")