import Foundation
let pattern = #"(.+D )\d{4}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Priority Controller DB8009 120D 4312
Priority Controller DB8009 120D 4312
Priority Controller DB8008 130D 4000
Priority Controller DB8009 110D 4222
Priority Controller DB8008 120D 3000
Priority Controller DB8009 120D 2000
Priority Controller DB8009 110D 6003
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)