package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+D )\d{4}`)
var str = `Priority Controller DB8009 120D 4312
Priority Controller DB8009 120D 4312
Priority Controller DB8008 130D 4000
Priority Controller DB8009 110D 4222
Priority Controller DB8008 120D 3000
Priority Controller DB8009 120D 2000
Priority Controller DB8009 110D 6003`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}