const regex = /(.+D )\d{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+D )\\d{4}', 'gm')
const str = `Priority Controller DB8009 120D 4312
Priority Controller DB8009 120D 4312
Priority Controller DB8008 130D 4000
Priority Controller DB8009 110D 4222
Priority Controller DB8008 120D 3000
Priority Controller DB8009 120D 2000
Priority Controller DB8009 110D 6003`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}