use strict;
my $str = 'Priority Controller DB8009 120D 4312
Priority Controller DB8009 120D 4312
Priority Controller DB8008 130D 4000
Priority Controller DB8009 110D 4222
Priority Controller DB8008 120D 3000
Priority Controller DB8009 120D 2000
Priority Controller DB8009 110D 6003';
my $regex = qr/(.+D )\d{4}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}