# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(\w+)\s*-\s*(\w+)\b/\1 to \2/gm;t' <<< "I'm going to be out of the office from 2-4pm or I'm out of the office from 10am-noon tomorrow"