package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(\w+)\s*-\s*(\w+)\b`)
var str = `I'm going to be out of the office from 2-4pm or I'm out of the office from 10am-noon tomorrow`
var substitution = "\1 to \2"
fmt.Println(re.ReplaceAllString(str, substitution))
}