import Foundation
let pattern = #"\b(\w+)\s*-\s*(\w+)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"I'm going to be out of the office from 2-4pm or I'm out of the office from 10am-noon tomorrow"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 to \2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)