#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(\w+)\s*-\s*(\w+)\b"
Local $sString = "I'm going to be out of the office from 2-4pm or I'm out of the office from 10am-noon tomorrow"
Local $sSubst = "\1 to \2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)