const regex = /\b(\w+)\s*-\s*(\w+)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\w+)\\s*-\\s*(\\w+)\\b', 'gm')
const str = `I'm going to be out of the office from 2-4pm or I'm out of the office from 10am-noon tomorrow`;
const subst = `\1 to \2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);