re = /\b(\w+)\s*-\s*(\w+)\b/m
str = 'I\'m going to be out of the office from 2-4pm or I\'m out of the office from 10am-noon tomorrow'
subst = '\\1 to \\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result