using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\w+)\s*-\s*(\w+)\b";
string substitution = @"\1 to \2";
string input = @"I'm going to be out of the office from 2-4pm or I'm out of the office from 10am-noon tomorrow";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}