#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,3}(?:,\d{1,3}){0,3}(?: ; \d{1,3}(?:,\d{1,3}){0,3})*$"
Local $sString = "10" & @CRLF & _
"10,10 ; 5,5" & @CRLF & _
"10,11,12,13 ; 20,30 ; 50" & @CRLF & _
"" & @CRLF & _
"10 ," & @CRLF & _
"10,10,999 ; 10,10 ,;" & @CRLF & _
"10,10 ; , 10;10,10" & @CRLF & _
"10 ;; 10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")