import re
regex = re.compile(r"^\d{1,3}(?:,\d{1,3}){0,3}(?: ; \d{1,3}(?:,\d{1,3}){0,3})*$", flags=re.MULTILINE)
test_str = ("10\n"
"10,10 ; 5,5\n"
"10,11,12,13 ; 20,30 ; 50\n\n"
"10 ,\n"
"10,10,999 ; 10,10 ,;\n"
"10,10 ; , 10;10,10\n"
"10 ;; 10")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")