re = /^\d{1,3}(?:,\d{1,3}){0,3}(?: ; \d{1,3}(?:,\d{1,3}){0,3})*$/m
str = '10
10,10 ; 5,5
10,11,12,13 ; 20,30 ; 50
10 ,
10,10,999 ; 10,10 ,;
10,10 ; , 10;10,10
10 ;; 10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end