import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{1,3}(?:,\\d{1,3}){0,3}(?: ; \\d{1,3}(?:,\\d{1,3}){0,3})*$";
final String string = "10\n"
+ "10,10 ; 5,5\n"
+ "10,11,12,13 ; 20,30 ; 50\n\n"
+ "10 ,\n"
+ "10,10,999 ; 10,10 ,;\n"
+ "10,10 ; , 10;10,10\n"
+ "10 ;; 10";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}