const regex = /^\d{1,3}(?:,\d{1,3}){0,3}(?: ; \d{1,3}(?:,\d{1,3}){0,3})*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{1,3}(?:,\\d{1,3}){0,3}(?: ; \\d{1,3}(?:,\\d{1,3}){0,3})*$', 'gm')
const str = `10
10,10 ; 5,5
10,11,12,13 ; 20,30 ; 50
10 ,
10,10,999 ; 10,10 ,;
10,10 ; , 10;10,10
10 ;; 10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}