use strict;
my $str = '10
10,10 ; 5,5
10,11,12,13 ; 20,30 ; 50
10 ,
10,10,999 ; 10,10 ,;
10,10 ; , 10;10,10
10 ;; 10';
my $regex = qr/^\d{1,3}(?:,\d{1,3}){0,3}(?: ; \d{1,3}(?:,\d{1,3}){0,3})*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}