using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[\w]+\s*)*(\d*-\d*\s*[A-Z0-9]+\s*\([a-z]\)\s*([A-Z]*\s*\d*))\s*";
string input = @"Utorak 10-13 RBP (v) JAG 2 14-16 A2 (v) BIM
Sreda 9-12 PPJ (v) 718 12-14 RBP (p) 821 14-16 PPJ (p) 718
Cetvrtak 11-14 RG (v) BIM 14-16 RG (p) BIM ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}