$re = '/(^[\w]+\s*)*(\d*-\d*\s*[A-Z0-9]+\s*\([a-z]\)\s*([A-Z]*\s*\d*))\s*/m';
$str = 'Utorak 10-13 RBP (v) JAG 2 14-16 A2 (v) BIM
Sreda 9-12 PPJ (v) 718 12-14 RBP (p) 821 14-16 PPJ (p) 718
Cetvrtak 11-14 RG (v) BIM 14-16 RG (p) BIM ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);