import re
regex = re.compile(r"(^[\w]+\s*)*(\d*-\d*\s*[A-Z0-9]+\s*\([a-z]\)\s*([A-Z]*\s*\d*))\s*", flags=re.MULTILINE)
test_str = ("Utorak 10-13 RBP (v) JAG 2 14-16 A2 (v) BIM\n"
"Sreda 9-12 PPJ (v) 718 12-14 RBP (p) 821 14-16 PPJ (p) 718\n"
"Cetvrtak 11-14 RG (v) BIM 14-16 RG (p) BIM ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")