const regex = /(^[\w]+\s*)*(\d*-\d*\s*[A-Z0-9]+\s*\([a-z]\)\s*([A-Z]*\s*\d*))\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[\\w]+\\s*)*(\\d*-\\d*\\s*[A-Z0-9]+\\s*\\([a-z]\\)\\s*([A-Z]*\\s*\\d*))\\s*', 'gm')
const str = `Utorak 10-13 RBP (v) JAG 2 14-16 A2 (v) BIM
Sreda 9-12 PPJ (v) 718 12-14 RBP (p) 821 14-16 PPJ (p) 718
Cetvrtak 11-14 RG (v) BIM 14-16 RG (p) BIM `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}